1分钟部署网站📞AI智能客服,大模型训练自有数据,简单好用,有效降低客服成本 广告
## 升级环境建议 PHP版本:7.4 MySQL版本:5.7(同2.0) 服务器软件:nginx/1.18.0(同2.0) ## 那些项目适合升级2.0 | 条件 | 建议 | | --- | --- | | 所有外网系统2.0版本 | 建议升级 | 1、由于3.0版本需要站点目录下的所有目录可写可读,因此如果使用了云锁、护卫神防篡改等安全防护软件时,系统的安装应用、升级应用、卸载应用等功能将无法使用。 2、3.0版本系统必须使用PHP7.4版本,否则会报错; 3、外网系统1.0版本升级到3.0不能直接升级、需要先将1.0系统升级到2.0,在进行3.0升级 4、2.0到3.0可进行平滑升级、无需备份网站及数据库; ## 2.0升级3.0方法 1、升级前需进入更新站-控制中心-客户管理-新建客户,然后在列表得到该站点授权码; 2、进入更新站点手动修改文件:/Config/Auth.php;将第一步得到的授权码复制到authToken; 3、登录2.0后台、进入应用市场升级:系统、会员管理、应用市场、安装完成之后退出后台登录即可完成3.0升级; 4、3.0版本新增:统计、首页信息、应用市场广告、系统信息、个人中心等功能、详情查看下一章; ## 3.0版本注意事项 1:新开发接口报:【权限不足提示】;处理方法:找到文件:/Root/V6/config/noLogin.php;追加相关信息即可;该方法仅用于无需登录或没有安装权限应用时使用;如安装权限应用需到权限管理配置相关节点; 2:出现后台登录失败、一般来说是因为云锁拦截了登录缓存写入: 处理方法:需要将自定义缓存文件夹【Public/cacheDiy/】写入防篡改白名单中、如下图 ![](https://img.kancloud.cn/be/09/be09f80c8a24c8eaca3188e8ea65bdd9_545x474.png)