## 全栈开发 安装全栈开发的程序骨架。 ## 环境要求 * Linux, OS X, WSL * PHP >= 7.2 * Swoole >= 4.4.4 (websocket >= 4.4.15) ## 安装框架 ### 安装 Swoole 扩展 推荐 [编译安装](https://wiki.swoole.com/wiki/page/6.html): ~~~ $> wget ***.tar.gz $> tar zxvf ***.tar.gz $> cd swoole-src $> phpize $> ./configure --enable-openssl --with-php-config=/usr/local/php72/bin/php-config $> make && sudo make install ~~~ ### 安装开发骨架 > 不要使用 git clone 安装 使用 [composer](https://www.phpcomposer.com/) 安装: ```shell composer create-project --prefer-dist mix/mix-skeleton:~2.2.0 mix ``` ### 确认安装成功 查看帮助: ~~~ $> php bin/mix.php --help ~~~ ## 安装热更新工具 - SwooleFor:[https://github.com/mix-php/swoolefor](https://github.com/mix-php/swoolefor)