# 环境依赖 仅支持 Linux,FreeBSD,MacOS,3类操作系统 Linux 内核版本 2.3.32 以上 PHP-5.3.10 以上版本,包括PHP7 gcc4.4 以上版本或者clang cmake2.4+,编译为 libswoole.so 作为 C/C++ 库时需要使用 cmake 建议使用 Ubuntu14、CentOS7 或更高版本的操作系统 # PHP版本依赖 Swoole-1.x需要 PHP-5.3.10 或更高版本 Swoole-2.x需要 PHP-7.0.0 或更高版本 不依赖 PHP 的 stream、sockets、pcntl、posix、sysvmsg 等扩展。PHP 只需安装最基本的扩展即可 推荐使用的Linux发行版 CentOS6.2+ Ubuntu12+ Debian6+ 其他见[swoole官方文档](https://wiki.swoole.com/wiki/page/7.html)