ThinkChat🤖让你学习和工作更高效,注册即送10W Token,即刻开启你的AI之旅 广告
>[danger] 情景再现 相信很多人微擎老司机都会遇到这么一个问题 同一个微擎站点上很多应用,但是不同应用间的PHP版本要求不一样 有的应用PHP版本要求必须5.6,有的应用PHP版本要求必须7.2,那么这就不好办了 本章节就是来处理这个问题的,同一个站点给不同的应用配置不同的PHP版本 **虽然可以这样处理,但还是推荐一个站点一个PHP版本** >[danger] 配置步骤 ``` location ~ [^/]\.php(/|$) { if ($request_uri ~* "lingchi_lottery_draw"){ fastcgi_pass unix:/tmp/php-cgi-72.sock; } fastcgi_pass unix:/tmp/php-cgi-56.sock; fastcgi_index index.php; include fastcgi.conf; include pathinfo.conf; } ``` ![](https://img.kancloud.cn/53/fa/53fafc849ff3483f4f466800c0f08998_634x422.png)