💎一站式轻松地调用各大LLM模型接口,支持GPT4、智谱、星火、月之暗面及文生图 广告
系统当前环境:OS X Yosemite 10.10.3 折腾时间:2015.5.7 刚开始尝试通过官方[http://thrift.apache.org/](http://thrift.apache.org/) 去编译安装,过程遇到坑无数。 其中提示bison版本过低,原因:Xcode中自带的bison是2.3的,而Thrift 0.9.2版本需要bison > 2.5版本。 折腾半天没解决 好人提供解决思路: 把xcode bison 改个名字,重新编译,然后再把名字改回来。 据说就好了! 本人未测试过。 最方便简单暴力的方式是用:brew [https://github.com/apache/thrift](https://github.com/apache/thrift) 官方的安装实在是太麻烦了,我使用brew安装变得特别简单 [http://stackoverflow.com/questions/23455499/cant-install-thrift-on-mac-os-10-9-2](http://stackoverflow.com/questions/23455499/cant-install-thrift-on-mac-os-10-9-2) 先 sudo brew update   再 sudo brew install thrift 安装完成后,直接在 ![](https://box.kancloud.cn/2016-05-16_57396c27ed8e0.jpg) 并且系统还会在 usr/local/bin下面增加一个链接   (由于我自己将我们自己生成的thrift命令拷贝到了usr/local/bin下,所以会出现一个警告,说我已经有一个链接了,问我是否覆盖 ,覆盖用命令 brew link --overwrite thrift) 使用这个命令,直接覆盖了,生成一个软连接,到thrift ![](https://box.kancloud.cn/2016-05-16_57396c28165e9.jpg) 使用的话 可以先用 thrift -help来查看命令