该组件依赖于`MaxPHP`,`Max-Framework`,所以需要先安装`MaxPHP` ```shell composer create-project max/max . ``` 如果你已经安装,但是却没有安装`Max-Database`,需要使用下面的命令安装 ```shell composer require max/database ``` > 安装完成后自动会将数据库配置文件`database.php`移动到框架的`config`目录下,如果没有移动则需要手动创建,配置文件实例如下 ```php <?php return [ //默认数据库配置 'default' => env('database.default', 'mysql'), 'mysql' => [ //如果有这项会优先使用DSN 'dsn' => '', //主机地址 'host' => env('database.host', 'localhost'), //数据库用户名 'user' => env('database.user', 'user'), //数据库密码 'pass' => env('database.pass', 'pass'), //数据库名 'dbname' => env('database.dbname', 'dbname'), //端口 'port' => env('database.port', 3306), //额外设置 'options' => env('database.options', [\PDO::ATTR_ERRMODE => \PDO::ERRMODE_EXCEPTION]), //编码 'charset' => env('database . charset', 'utf8mb4'), //数据表前缀 'prefix' => '' ], ] ``` 目前支持`MySQL`,`PostgreSQL`